wkt's blog
非学无以致疑,非问无以广识

ubuntu下twisted安装错误解决

admin~2018年8月9日 /常用备份/笔记

本机环境 python3.6, 使用pip install twisted时候出现错误:

Command ... /home/wukt/.virtualenvs/spiderenv/include/site/python3.6/twisted" failed with error code 1 in /tmp/pip-install-k06rgbaf/twisted/

同时造成无法正常安装scrapy框架。

解决方法

  1. 下载安装文件
wget https://pypi.python.org/packages/c0/7c/c1e5b61e30b7ffc96576d2a922615c8068e6996a622be813fc626cef07aa/Twisted-16.3.0.tar.bz2#md5=e044af844623e9fbcbe29f578db6053a
  1. 解压
tar jxvf Twisted-16.3.0.tar.bz2
  1. 安装
cd Twisted-16.3.0
python setup3.py install 

等待twisted安装成功后可以再使用pip install scrapy正常安装scrapy。

发表评论

电子邮件地址不会被公开。